The issue causing the Translation API was resolved. All systems are stable and working as expected now
Posted Feb 13, 2026 - 13:04 UTC
Monitoring
We implemented fix to stabilize the Translation API and support the required load value. All systems are functional now. We keep monitoring the performance to unsure proper translation operations processing
Posted Feb 13, 2026 - 12:20 UTC
Identified
The issue was caused by unexpectedly high load on the Translation API and inability of the translation queue to be processed in according rate. Now R&D is working on the translation queue parameters to meet the required processing rate
Posted Feb 13, 2026 - 11:13 UTC
Investigating
We detected Translation API performance degradation. Some users experiencing slower API responses. We are investigating the issue.
Posted Feb 13, 2026 - 10:54 UTC
This incident affected: Intento Language Hub (Text Translation, File Translation).