Translation Storage Slowdown

Incident Report for Intento Public

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 14:51 UTC

Monitoring

The Translation Storage functionality was fully restored.
We are monitoring the service performance and preparing the RCA.
Posted Aug 05, 2025 - 14:29 UTC

Investigating

An unexpected usage spike led the Translation Storage slowing down. We are working on the fix now.
Posted Aug 05, 2025 - 12:41 UTC
This incident affected: Intento Language Hub (Translation Cache).